Browse Source

Fix mod_compress to compile with old gcc version (#1592)

git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@2128 152afb58-edef-0310-8abb-c4023f1b3aa9
svn/tags/lighttpd-1.4.20
Stefan Bühler 14 years ago
parent
commit
adec5443ee
  1. 2
      NEWS
  2. 2
      src/mod_compress.c

2
NEWS

@ -5,7 +5,7 @@ NEWS
- 1.4.20 -
*
* Fix mod_compress to compile with old gcc version (#1592)
- 1.4.19 - 2008-03-10

2
src/mod_compress.c

@ -178,9 +178,9 @@ SETDEFAULTS_FUNC(mod_compress_setdefaults) {
}
if (!buffer_is_empty(s->compress_cache_dir)) {
struct stat st;
mkdir_recursive(s->compress_cache_dir->ptr);
struct stat st;
if (0 != stat(s->compress_cache_dir->ptr, &st)) {
log_error_write(srv, __FILE__, __LINE__, "sbs", "can't stat compress.cache-dir",
s->compress_cache_dir, strerror(errno));

Loading…
Cancel
Save