Browse Source

Add "lua-5.1" to searched pkg-config names for lua

git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@2571 152afb58-edef-0310-8abb-c4023f1b3aa9
svn/tags/lighttpd-1.4.24
Stefan Bühler 13 years ago
parent
commit
8f61a1ffd0
  1. 1
      NEWS
  2. 16
      configure.ac
  3. 2
      src/CMakeLists.txt

1
NEWS

@ -12,6 +12,7 @@ NEWS
* Fix config evaluation for debug.log-timeouts option (#1529)
* Add "cgi.execute-x-only" to mod_cgi, requires +x for cgi scripts (fixes #2013)
* Fix FD_SETSIZE comparision warnings
* Add "lua-5.1" to searched pkg-config names for lua
- 1.4.23 - 2009-06-19
* Added some extra warning options in cmake and fix the resulting warnings (unused/static functions)

16
configure.ac

@ -417,11 +417,17 @@ if test "$WITH_LUA" != "no"; then
AC_DEFINE([HAVE_LUA], [1], [liblua])
AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
],[
# for debian based systems
PKG_CHECK_MODULES(LUA, lua5.1 >= 5.1, [
AC_DEFINE([HAVE_LUA], [1], [liblua])
AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
])
# for debian based systems
PKG_CHECK_MODULES(LUA, lua5.1 >= 5.1, [
AC_DEFINE([HAVE_LUA], [1], [liblua])
AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
],[
# for freebsd
PKG_CHECK_MODULES(LUA, lua-5.1 >= 5.1, [
AC_DEFINE([HAVE_LUA], [1], [liblua])
AC_DEFINE([HAVE_LUA_H], [1], [lua.h])
])
])
])
AC_SUBST(LUA_CFLAGS)

2
src/CMakeLists.txt

@ -342,7 +342,7 @@ IF(WITH_LDAP)
ENDIF(WITH_LDAP)
IF(WITH_LUA)
pkg_search_module(LUA REQUIRED lua lua5.1)
pkg_search_module(LUA REQUIRED lua lua5.1 lua-5.1)
MESSAGE(STATUS "found lua at: INCDIR: ${LUA_INCLUDE_DIRS} LIBDIR: ${LUA_LIBRARY_DIRS} LDFLAGS: ${LUA_LDFLAGS} CFLAGS: ${LUA_CFLAGS}")
SET(HAVE_LIBLUA 1 "Have liblua")
SET(HAVE_LUA_H 1 "Have liblua header")

Loading…
Cancel
Save