Browse Source

[build] prepend search for lua version 5.4

master
Glenn Strauss 2 months ago
parent
commit
64aff80d86
4 changed files with 4 additions and 4 deletions
  1. +1
    -1
      SConstruct
  2. +1
    -1
      configure.ac
  3. +1
    -1
      src/CMakeLists.txt
  4. +1
    -1
      src/meson.build

+ 1
- 1
SConstruct View File

@ -579,7 +579,7 @@ if 1:
if env['with_lua']:
found_lua = False
for lua_name in ['lua5.3', 'lua-5.3', 'lua5.2', 'lua-5.2', 'lua5.1', 'lua-5.1', 'lua']:
for lua_name in ['lua5.4', 'lua-5.4', 'lua5.3', 'lua-5.3', 'lua5.2', 'lua-5.2', 'lua5.1', 'lua-5.1', 'lua']:
print("Searching for lua: " + lua_name + " >= 5.0")
if autoconf.CheckParseConfigForLib('LIBLUA', "pkg-config '" + lua_name + " >= 5.0' --cflags --libs"):
autoconf.env.Append(CPPFLAGS = [ '-DHAVE_LUA_H' ])


+ 1
- 1
configure.ac View File

@ -1359,7 +1359,7 @@ if test "$WITH_LUA" != no; then
LUA_CFLAGS="-I$WITH_LUA"
fi
else
for luaname in lua5.3 lua-5.3 lua5.2 lua-5.2 lua5.1 lua-5.1 lua; do
for luaname in lua5.4 lua-5.4 lua5.3 lua-5.3 lua5.2 lua-5.2 lua5.1 lua-5.1 lua; do
if test "$found_lua" = "0"; then
PKG_CHECK_MODULES([LUA], [$luaname >= 5.1],
[found_lua=1],


+ 1
- 1
src/CMakeLists.txt View File

@ -645,7 +645,7 @@ else()
endif()
if(WITH_LUA)
pkg_search_module(LUA REQUIRED lua5.3 lua-5.3 lua5.2 lua-5.2 lua5.1 lua-5.1 lua)
pkg_search_module(LUA REQUIRED lua5.4 lua-5.4 lua5.3 lua-5.3 lua5.2 lua-5.2 lua5.1 lua-5.1 lua)
message(STATUS "found lua at: INCDIR: ${LUA_INCLUDE_DIRS} LIBDIR: ${LUA_LIBRARY_DIRS} LDFLAGS: ${LUA_LDFLAGS} CFLAGS: ${LUA_CFLAGS}")
set(HAVE_LIBLUA 1 "Have liblua")
set(HAVE_LUA_H 1 "Have liblua header")


+ 1
- 1
src/meson.build View File

@ -380,7 +380,7 @@ endif
liblua = []
if get_option('with_lua')
found_lua = false
foreach l: ['lua5.3', 'lua-5.3', 'lua5.2', 'lua-5.2', 'lua5.1', 'lua-5.1', 'lua']
foreach l: ['lua5.4', 'lua-5.4', 'lua5.3', 'lua-5.3', 'lua5.2', 'lua-5.2', 'lua5.1', 'lua-5.1', 'lua']
if not(found_lua)
liblua = dependency(l, required: false)
if (liblua.found())


Loading…
Cancel
Save